適合在 WordPress 2.1 上使用的 plugins

升級前,還是多作確認比較保險...

因為 WordPress 2.1 今天推出了 RC 1 的版本(詳情可見此),正式版應該沒多久就要推出了,而之前也有許多長輩提過 WP 2.0 升級到 WP 2.1 可能碰到的問題,對一般使用 WordPress 的人來說,會碰到問題大多是因為 plugin 在新的架構下可能會出錯,所以除非 plugin 的作者釋出能用在 WP 2.1 上的版本,否則你可能就要自己想辦法啦!

還好 WordPress 的開發團隊相當用心,整理了一份 Plugins/Plugin Compatibility/2.1 的列表,列出由他們測試過於 WP 2.1 上執行而沒問題的 plugins ,如果你有使用的 plugins 都有在這個列表裡的話,那應該就能比較放心升級啦~(看起來我挺幸運的,使用的 plugins 都有在列表裡...)

不過仍然有個隱憂, theme 裡面有可能會用到在 WP 2.1 上無法使用的語法,這個就要花點心思改囉。(不過根據我看 svn 版本的 code,有些還是會放在 wp-includes/deprecated.php ,代表還能用一段時間吧 XD)