WordPress 2.0.7 釋出

跟前幾天釋出的 2.0.6 比起來,只有小小的改變,或許也可以等到月底直接升級 2.1 版(心臟夠強的話...)?

跟據這篇文章的說法,這個版本跟 2.0.6 比起來只更動了幾個檔案如下:

  • wp-admin/inline-uploading.php
  • wp-admin/post.php
  • wp-includes/classes.php
  • wp-includes/functions.php
  • wp-settings.php
  • wp-includes/version.php

所以如果想升級的人,可以只需替換這些檔案就好。

WP 2.0.7 除了更正之前被討論過的 對FeedBurner的bug 之外,同時也修改一些操作方式如:

  • Security fix for wp_unregister_GLOBALS() to work around the zend_hash_del_key_or_index bug in PHP 4 versions less than 4.4.3 and PHP 5 versions less than 5.1.4 with register_globals set to “On.”
  • Feeds now properly serve 304 Not Modified headers instead of mismatched 200/304 headers (a.k.a. the FeedBurner bug).
  • Backport of another 304 Not Modified fix from WordPress 2.1
  • Deleting WordPress Pages no longer gives an “Are You Sure?” prompt.
  • After deleting a WordPress Page, you are now properly redirected to the Edit Pages screen.
  • Sending an image at original size in Internet Explorer no longer adds an incorrect “height” attribute.

雖然 WP 2.1 預計在 1/22 就會釋出,不過開發人員也說了 「2.0 branch of WordPress will continue to be maintained for several years」 ,如果怕自己的 plugin 或 theme 會跟 2.1 有 conflict 的話,可以先用 WP 2.0.7 一陣子再說囉。